Saturday, October 15, 2016

How to Install Krop 0.4.11 (PDF Crop Tool) on Ubuntu 16.04/16.10 and Debian 8

   Krop is a simple graphical tool to crop the pages of PDF files. It is free software, released under GPLv3+ in the sole hope that you or someone else may find it useful.


A few tricks
  •     If you press Trim Margins on a page without selections, then krop will automatically create a region for the full page with the margins trimmed.
  •     If you are cropping a PDF file with many pages, then you may have some exceptional pages which need to be cropped in a different way then the other pages. In that case, the option Exceptions under Selections apply to will be useful to you.
  •     To add the dimensions of your own eReader to the 'Fit screen of device' choices, you can edit the configuration file. The location of this file may differ from system to system, but a good place to start looking is ~/.config/arminstraub.com/krop.conf. Don't forget to adjust the counter size= after adding your entries in the devicetypes section.
  •     Run krop with --help to get a list of possible arguments (for instance, --initialpage 5 starts krop with the fifth page open).
  •     If you run into the error "multiple definitions in dictionary" while cropping a file, then this is because pyPdf is too strict. You can either upgrade to PyPDF2 or proceed as indicated in this bug report. 
 Krop 0.4.11 Changelog :

  • Make krop compatible with both python2 and python3. 

 Installation instructions:

     Run the following commands in Terminal to install :

$ sudo apt-get install gdebi

$ sudo apt-get install python-poppler-qt4 python-pypdf2

$ wget http://arminstraub.com/downloads/krop/krop_0.4.11-1_all.deb

$ sudo gdebi krop_0.4.11-1_all.deb

 Once installed, Krop can be launched from Unity Dash or your favorite application launcher.

No comments:

Post a Comment